Mac-Clean Up >Problem

This topic contains 5 replies, has 2 voices, and was last updated by  JR – CleverFiles 4 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7887

    lartis
    Participant

    I may have made a terrible error. I downloaded the Pro version of Disk Drill. Thinking I was being wise and preventing future problems, I ran the Clean Up function. Later yesterday, I needed to d/l a dmg file but when I went to install it I repeatedly received a 4960 error. As I understand it, some file is now missing that is integral to Mac’s operating system. I am semi capable but apparently not capable enough when it comes to my computer skills. Is there a way to completely restore every file to its original place? Am I hosed? Please help. I am desperate and really do no want to have to fdsk my computer or whatever the Mac version of that is.

    Thanks
    Linda

    #7888

    The only way to accomplish what you want to do is using a Time Machine backup and restoring the state of your computer to one of those backups in the past. But it sounds like you did not make any backups.

    Unless you cleaned your Mac moving all the files to Trash (instead of deleting them right away), and you did not empty the Trash, I would assume the cleaned files are gone and not easily recoverable. You can also run Disk Drill’s data recovery algorithms to see what can be restored, and you might be lucky to have enabled the protection options as well: Recovery Vault and Guaranteed Recovery, if you did, more of your files can still be recovered from within Disk Drill.

    #7889

    lartis
    Participant

    I am not sure I really understood much of what you said but this is what I was able to do and this is where I stand now:

    I ran Disk Drill and was able to recover what I think were the files crucial to the failures I experienced the other day. I see primarily BaseSytem, SystemVersion, PlatformSupport, disk_label, _journal, boot files. I did go on, however, to scan for all files deleted in like…forever…because I was paranoid. So I have a ridiculously long list that it would make no sense to recover but I just needed all my options available.

    Now, I’m confronted with an option to “Recover 13 files/516.9MB to: Choose folder… Recover . OK this is where I’m totally confused. The 13 files represent those files that appear to me to be systems files. I’m assuming they are the ones that provoked the error 4960 since the Disk Drill that removed those plus other documents, photos, and others occurred just before I got that error. (It might be worth noting that I also lost my 1Password startup/app, my Safari extensions, and I’m not sure what else. That’s all I know of at this point.) All I want is for these files to return to their original locations. When I select the drop down for “Choose folder” I get of course a listing of all my folders. Beneath that is this:
    Warning: If you select destination fold at the same disk where deleted files are, this will substantially lower your recovery chances.
    There is then a click box that says: Ignore original structure of folders for recovered items.

    I can select any of my existing folders, or create a new folder. I can insert a flash drive but am not sure what the value of that is. I do have the files on something other than the same disk but I still don’t have any idea where to place them. I had hoped they would simply be replaced where they came from.

    As you can tell, I need serious help. I am sorry, if I am a burden.

    Linda

    • This reply was modified 4 months, 4 weeks ago by  lartis.
    #7892

    Linda, if you did not create a backup of your files, it’s almost impossible to recover them to their _original_ locations, as they are not known. Data recovery works in a way to at least save the data, when the previous (before the deletion) location is also recoverable, you will see it, but you will still have to recover your data to another location and then move the files “back” manually.

    #7893

    lartis
    Participant

    Actually I somehow managed to replace or repair everything as far as I can tell with the exception of the 4960 error that keeps occurring after d/l an update to a program.

    This seems as if it’s an impossible problem to fix. I can’t believe this one little thing is going to make me have to do something drastic to my whole computer to fix it.

    #7895

    Did you do your online research on this error? I don’t seem it’s anyhow related to your file activity and might be coming from a deeper system-related configs: https://discussions.apple.com/thread/790599?start=0&tstart=0

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.