Can Drill Disk help a NTFS External Hard Drive plugged into a Mac

Disk Drill for Mac and Windows – Help Center Forums General Can Drill Disk help a NTFS External Hard Drive plugged into a Mac

This topic contains 1 reply, has 2 voices, and was last updated by  mynameisJR 6 years, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #4454


    Ok, I’m very worried. I have a situation that I don’t know what to do about.
    I have OS X 10.8.3, (mid-2010) MacBook Pro 13″, 2.4 GHz Intel Core 2 Duo, 8 GB DDR3, NVIDIA GeForce 320M 256 MB.
    External HD is a 3TB Seagate GoFlex Desk Media.

    The issue is that I cannot drill down very far to access files I use to be able to access just fine.

    Here is the history of the External HD [xHD], to the best of my memory. I originally formatted it to some sort of format (I don’t remember what!) that made me be able to use the xHD on Mac and PC. I think things were fine. I didn’t really swap between computers much. I thought I was able to read/write from both separate computers before.
    Well… I recovered my Mac at some point and lost the permissions. I had a tech friend that fixed the permissions. I think he used a program called NTFS for Mac OS X (I’m not sure). So it worked fine–was able to read/write to the xHD. I never plug it into the PC. I don’t have another 3TB xHD that I can transfer the data onto, so I can reformat my existing xHD to the proper Mac format. Anyway. Months later, I wanted to wipe my Mac. I tried to use the xHD, but I couldn’t write to it. It seemed to notice it was in a format that seemed like it should be for PC. I think NTFS.
    My friend was unavailable so I had to figure out how to write to my xHD. Later discovered he probably used ‘NTFS for Mac OS X.’ I had been using my xHD for a long time. This app made the xHD that was unwritable, and converted it to Format: Windows NT Filesystem (at least that’s what it says now). The xHD info says I can read and write.

    Ok, now here is what I did wrong.
    I have this app called Quicksliver (a Finder-type app). I added my xHD to it’s ‘Catalog.’
    I was organizing my pictures… just plain ol’ .jpg files.
    I had Aperture open. It seemed like moving the files were slow. Then I realized, I should quit Aperture in case It’s trying to keep up with what I’m doing. I have a large Photo Library and am not sure if Aperture was trying to do some Processes as I was moving the photos. Photos were moving fine, but just Finder was slow. Maybe because Quicksilver was scanning the drive too. (I should’ve had added the xHD until I had time for it to just sit and scan.)

    Tried to quit Aperture. It took its time to shut down… had a progress bar. I left it alone. Then after a while the progress bar finished, then another progress bar for Aperture came up and I let that one finish too. I didn’t want to mess anything up. Well a long time went by and I DID stop moving photos while Aperture was quitting. But waiting for it to quit took a LONG time. So I tried to quit Quicksilver. Everything was so slow. I thought maybe it was Google Drive or Dropbox in my menu bar at the top. I turned off my wireless (that took a while to respond). Then so was Google Drive and Dropbox. Both took a while to respond. Anyway. Next I tried to shut down the computer. Aperture made it not quit (i think) So I waited a while and had to Force Quit. Then later my xHD wouldn’t let my computer shut down (in the future of this story I think it was the fact I added my xHD to Quicksilver’s catalog and it was still trying to scan my files in the background–I am not sure of this but is my uneducated guess. I then tried to eject my xHD. It wouldn’t eject. I waited and waited. It never ejected. I had the option to ‘Force Eject.’ Then it warned me that I might experience problems. I didn’t want this… But after waiting and several atempts to eject even using Disk Utility. I couldn’t even access Quicksilver. Everything was slow. I wanted to (or didn’t think of it at the time) remove the xHD from Quicksilver’s Catalog. I am not sure all what happened in detail. But eventually I did force eject!! Then tried to shut down. I got the gray shut down screen. It was on for 10 minutes. I needed to get back on the computer. I pushed and held the power button then restarted.

    Continuing with the story. I eventually stopped Google Drive and Dropbox from starting up upon start up. Computer was acting slow still. I tried ejecting the xHD. Did another force eject after exploring all my options. I shut down then rebooted my computer again. Then it was at this time that I removed the xHD from the Quicksilver Catalog. It seemed things were operating faster (a little). Apps responded to opening. But because it was a little slow. I tried to eject the xHD. It ejected now (now that I disattached Quicksilver from it). So I then unplugged the xHD and rebooted Mac. All I want to do is go back into the Finder and drag/drop those files of pictures. Well I could only go a couple folders deep into the xHD.
    What happened!!!
    GOOGLED IT! There is too much resource out there. I’m SO glad I stumbled upon this one fella saying he had success with Disk Drill. So I looked on your website. I was almost about to buy, but then since I doubted the fact that I could recover anything since my peculiar formating-work-around issues (like having a Mac read Windows NT Filesystem). So I took your advice and downloaded the free version and did a ‘Recover Data’ (couldn’t ‘Prevent data loss’ due to the format). Did a quick scan. The initial progress bar went by within 5 minutes. That went fast but now it’s hung up on that striped progress bar and after almost an hour, it has found 4 recovered items.
    I feel like I don’t know if I’ll be able to access those files.

    I’m writing to ask you if you think if your program could allow me to get that access back to be able to get back to those files that aren’t showing up any more.
    Obviously I don’t want to re-format my xHD. And I’m not a genius with this program called NTFS for Mac OS X. So I don’t know how all this works, but I’m hoping your software can allow me to access those files.

    I’m willing to buy the program from the Mac App Store.

    On Disk Utility, the xHD says:
    Write Status: Read/Write
    S.M.A.R.T. Status: Not supported
    Partition Map Scheme: Master Boot Record

    I cannot Verify Disk because Disk Utility says it won’t unmount. (Well that was before I removed the xHD from Quicksilver and quit Quicksilver). Haven’t tried to Verify Disk since then. But right now I’m using Disk Drill to scan the xHD. Won’t use Disk Utility at the moment.

    Please help. I don’t know who to talk to.
    So far I like your software, but I think I might not be able to recover my files.

    Basically I feel I messed things up when I forced Ejected the xHD and then shut down… Gray screen was showing forever and I held down the power button until everything shut down. Not to mention after the second reboot in the (above) story, the USB plugged into my Mac was sensitive to moment and it didn’t Eject properly twice in a row.




    First, we don’t recommend trying Disk Drill Basic and then buying Disk Drill Media Recovery, as the App-Store version of Disk Drill is a completely different edition and lacks many features of the Disk Drill app available directly from our website. Secondly, the only guarantee we can give you is: preview the files that were located as a result of scanning your drive. If your files can be correctly previewed, they will be correctly recovered. If you still are having issues completing the scan, please, try to quit Disk Drill and start scanning again, and use an alternative recovery method, like Deep Scan for instance.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.